Get Adobe Flash player

Smart OSD


thread im Forum (engl.), thread im Forum (deu.), www.smart-electronics.eu, aktuelle Firmware osd_2_35.bin 08.05.2014
primary_font oder primary_bold oder system_font oder tiny_font oder secondary_font und third_font - OSDsymbols oder
third_font - OSDsmallsymbols

meine aktuelle Config für das Smart OSD mit der DP1

Bild lädt

mit dem Smart OSD können jetzt die Ströme der einzelnen BL Regler eingeblendet werden, leider ist meine Motorenanordnung
noch nicht auswählbar...

Bild lädt

alles arbeitet perfekt!

Bild lädt

ab der Firmware 2.22 kann die Smart OSD Config über das Wi232 Modul mit dem Smart OSD Manager bearbeitet werden,
dazu nutze ich das PKT (transportables Koptertool) in der Betriebsart "MK-USB Funktion USB --> Wi.232"

Bild lädt

ab Firmware 2.19 müssen 3 verschiedene Fonts geladen werden

Bild lädt

ab Firmware 2.19 gibt es dieses "MK status panel"

Hinweise zur Inbetriebnahme eines Stromsensors:

- Anschluss an den Eingang "ad1" wenn der Sensor eine max. Ausgangsspannung von 5V hat
- Anzeige der Spannung an "ad1" über den External battery indicator 1 oder 2
- Abgleich des Analog inputs multipliers, damit die Ausgangsspannung des Sensors extakt in der Anzeige stimmt
- Abgleich der Auflösung des Sensors mV/A und des Volt/Nullabgleiches (ohne Last) bei External current Sensor
- Einstellen der Akkukapazität
- Vergleich der Stromanzeige im Videomonitor und einem Zangenampermeters in der Akkuzuleitung

erster Test der Firmware 2_18 mit dem neuen 50A Stromsensor

Bild lädt

die Ruhespannung des 50A Stromsensors beträgt ca. 2,50V und er besitzt eine Auflösung von ca. 39mV/A, die Stromaufnahme
bei 5V Betriebsspannung beträgt 10mA, der Offset wird in der Firmware des Smart OSD angepasst
ich nutze den 5V - Eingang "ad1" am Smart OSD mit einem Analog inputs multipliers von 1,665

die Daten vom 200A Sensor:
- Offset Spannung ist 2,50VDC bei 5VDC Versorgungsspannung
- Auflösung ist 0,0125mV/A

Bild lädt

Einbau des 50A Sensors, die 50A und 200A - Sensoren gibt es hier

Bild lädt

ein Draht vom Akku wird durch den 50A Sensor (auf die Richtung am Sensor achten!) geführt

Bild lädt

hier hat der 50A Sensor prima Platz

Bild lädt

der 50A Sensor wird mit dem Stecker (sw/ge) an das Smart OSD gesteckt und mit (rt) an die FC an einen freien Servo (+5V)

HTS-C50 Stromsensor 20 x 15 x 6 mm 4 g # 110 838
HTS-C50 Stromsensor (50A):
- Messbereich: 0 ~ 50 A
- Kabellänge 250 mm
- Auflösung: 0,1A
- Durchmesser Sensor: 6 mm

HTS-C200 Stromsensor 27 x 22 x 6 mm 7 g # 110 839
HTS-C200 Stromsensor (200A):
- Messbereich: 0 ~ 200 A
- Kabellänge 250 mm
- Auflösung: 1 A
- Durchmesser Sensor: 10 mm

bezüglich Umschaltung der insgesamt 4 Bildschirmen im Smart OSD schreibt aronax aus dem MK Forum:
"used for change OSD screen. The change occurs after sending PPM value higher than 1.6ms (aktiv position)
and return to value lower than 1.2ms (resting position). New software have new function, some changes
require a new set of items displayed in the OSD."

Bild lädt

zur Umschaltung der 4 Bildschirme verwende ich Servo 3 der FC und dort habe ich die Funktion "GPS_MODE_Coming Home" zugeordnet,
da ich diese nicht nutze und nur eine 8 Kanal Fernsteuerung habe...

Bild lädt

"Navigation map"

Bild lädt

"Radar"

Bild lädt

"MK Status panel"

Bild lädt

VideoIn und VideoOut sind richtig, deshalb stimmt die Grafik jetzt (Kamera Sigma DP1)

Bild lädt

erster Test, hier war noch VideoIn und VideoOut vertauscht, deshalb die schwarze Grafik

Bild lädt

Habe gerade einmal das Smart OSD mit dem OSD Manger über OSD verbunden und der FT 232 hat sich brav als COM3 gemeldet,
ich musste als erstes einige BT Treiber löschen, da der OSD Smart Manger mit den hohen COM - Ports, bei mir die COM 22
nicht klar kam. Danach habe ich die aktuelle Firmware osd_2_13.bin 20.11.2011 über USB eingespielt, das ging super schnell.

Im OSD Smart Manger kann man die Position und Größe der Elemente selbst bestimmen, hier einmal der Screen 1,
es gibt insgesamt 4 Screens die auf verschieden Weise umgeschaltet werden können.

Bild lädt

PKT arbeitet am 2.UART über Wi232 des Smart OSD einwandfrei

Einstellungen im Smart OSD Manger: Global Parameter -> Xbee Port & Buffered
wichtiger Hinweis: ein Videosignal muss eingespeist werden!

Bild lädt

so habe ich das Wi232 Modul angeschlossen

zum BT Modul schreibt dols aus dem MK Forum:

Problem is the voltage swing comming from the BT module. I don't know exactly why, maybe it's expecting a pull-down,
or the osd has an pull-up. Too little information to go on. But i have a workarround.
Use it at your own risk! I can't determen if it hurts either the OSD or the Bluetooth module.
"I soldered a 1Kohm resistor between pin 1 and pin 4 of the UART2.

To be complete, and maybe usefull to other users, the pinout:
4pin OSD > 10pin BT
Pin 1 > Pin 1
Pin 2 > Pin 9
Pin 3 > Pin 2
Pin 4 > Pin 7"

Bild lädt

hier ist das Smart OSD eingebaut

Bild lädt

die neuen Potis (2k) sind wesentlich "stabiler", damit lassen sich die Spannung sehr genau einstellen

Bild lädt

Bestückungsseite

Abgleich der beiden Potis, aronax aus dem MK Forum schreibt dazu:
"Please disconnect camera and video grabber and try to set R8 voltage on 2.2V (R9 should be something between 0.2-0.7V).
Then connect video signals. Check again voltage on R8."

Bild lädt

Leiterseite

Bild lädt

das ist alles bei der Lieferung dabei